Scheduled Maintenance
Incident Report for Play Football
Resolved
Start: Tuesday 23rd March 2:00AM
Update: The maintenance is to apply windows update. During the maintenance, the system (admin and registration) will not be accessible.
End: Tuesday 23rd March 2:30AM
Posted Mar 23, 2021 - 02:00 AEDT