PlayFootball Release Notes (28th of August 2026)

Incident Report for PlayFootball

Resolved

Added a warning message when a participant uploads a profile photo for the first time

Fixed a bug where refund requests with no FA fee could not be approved when Refund Finalisation Automation was enabled

Fixed a bug where selecting “Register Another Participant” at the end of the registration flow did not always filter Find a Product to the previously selected organisation

Fixed a bug where applying an organisation voucher after an AKV roll‑up incorrectly removed the AKV discount

For more details please see > https://support.playfootball.com.au/en/support/solutions/articles/22000296464-system-release-notes-28th-of-august-2026
Posted Aug 28, 2026 - 09:58 AEST
This incident affected: PlayFootball Release Notes.