PlayFootball Release Notes (5th of Dec 2025)

Incident Report for PlayFootball

Resolved

Removed ‘Copy & Paste’ as an option for Terms and Conditions upload

For organisations where the final disbursement amount is $0, all transactions will now be marked as disbursed/netted instead of to be disbursed or netted, with the settlement date set to when the transaction is processed through the disbursement service

Removed ‘Expression of Interest’ in product setup and product detail

Fixed a bug where the confirmation screen did not display ‘Registration Submitted’ when the product fee was $0 or reduced to $0 via vouchers

Please see further details here > https://support.playfootball.com.au/support/solutions/articles/22000293464-system-release-notes-5th-of-december-2025
Posted Dec 05, 2025 - 09:04 AEDT
This incident affected: PlayFootball Release Notes.