PlayFootball Release Notes (26th of March 2026)

Incident Report for PlayFootball

Resolved

Prevented bulk approval for registrations where the payment status is “Refund Requested”

Added a hidden registration group for Legacy MFC import types (Migration support only)

Blocked Club Admins from using “Copy URL” to register on behalf of participants as an Admin

Moved the school list into the database (instead of hard‑coded in the system) to make updates, additions, and removals easier

Fixed a bug where participants were not redirected back to the product after linking an existing participant record on their profile

Fixed a bug where Admins could not edit an approved registration type to remove all additional questions

Fixed a bug where delayed transactions were not updating their transaction status and date when the final tally amount was zero

Fixed a bug where the capacity limit field incorrectly marked the Details step as incomplete, even though it is optional for Regulatory Admin products
Posted Mar 26, 2026 - 08:08 AEDT
This incident affected: PlayFootball Release Notes.