PlayFootball Non-Playing Role Error

Incident Report for PlayFootball

Resolved

This incident has been resolved. Participants can now pass through the regulation detail step of a non playing registration.

Please see release notes > https://support.playfootball.com.au/support/solutions/articles/22000294695-system-release-notes-13th-of-march-2026
Posted Mar 13, 2026 - 07:56 AEDT

Investigating

Non-Playing Registration flow impacting existing participants

We are currently investigating an issue relating to Non-Playing registrations (coach, volunteer etc) where existing users are unable to bypass the WWCC step.

For a workaround contact support on 02 8880 7983.

We will provide more details once a fix is in place.
Posted Mar 12, 2026 - 12:36 AEDT
This incident affected: PlayFootball Participant (Registration Flow).