PlayFootball Release Notes (4th of August 2026)

Incident Report for PlayFootball

Resolved

Fixed a bug where AKV vouchers were no longer rolling up correctly on the Continue and Pay screen

Fixed a bug that prevented some registrations linked to the Minor ITC process from being submitted
Posted Aug 04, 2026 - 09:12 AEST
This incident affected: PlayFootball Release Notes.