PlayFootball Release Notes (21st of Nov 2025)

Incident Report for PlayFootball

Resolved

Automatically sending participants a confirmation email for refunds after FA approves the refund finalisation ticket

The amount displayed in the email is exclusive of transaction fees. Refunds for 2025 may still include transaction fees.

Updated the refund report so that:
Refund requests with Cancel and Decline status are no longer filtered out
Added ‘Date Processed’ and ‘Total Refunded’ columns

Updated the refund status pop-up:
Displays the date when the request was updated
Updated Finalised Message Text to show the date processed by FA and allow up to 7-business-day for the refund to appear in bank account

Added a Transaction Type column in the ledger to indicate whether a transaction is a payment or refund

Added a Transaction Type column in the Disbursement Report to indicate whether a transaction is a payment or refund


Updated the season filter in the system to 2026


Added a season filter to the ledger, defaulted to 2026

For more details please see > https://support.playfootball.com.au/support/solutions/articles/22000293358-system-release-notes-21st-of-november-2025
Posted Nov 21, 2025 - 09:11 AEDT
This incident affected: PlayFootball Release Notes.