PlayFootball Release Notes (28th of Oct 2025)

Incident Report for PlayFootball

Resolved

- Updated the Registration Confirmation page to show ‘Registration Submitted’ instead of ‘Payment Successful’ for zero-dollar products

It will still display 'Payment Successful' if the fee is reduced to zero via a voucher. This change also does not apply to 'Continue and Pay' or 'Admin Pay on Behalf' flows.

- Fixed a bug where clicking ‘Export Data to CSV’ from the All Registrations tab only exported the 10 records visible on the page instead of all data

- Fixed a bug where Admins bulk paying on behalf of registrations with a $0 fee saw the payment status remain as Unpaid

More details can be found here > https://support.playfootball.com.au/support/solutions/articles/22000293001-system-release-notes-28th-of-october-2025
Posted Oct 28, 2025 - 08:39 AEDT
This incident affected: PlayFootball Release Notes.