PlayFootball Release Notes (4th of September 2026)

Incident Report for PlayFootball

Resolved

Allowed participants to upload contracts through Supporting Documents for Professional ITC/DTC awaiting approval registrations

Fixed a bug where the response to the question “Was it with a different club or organisation to this registration?” was not saved when resuming a draft registration

For more details > https://support.playfootball.com.au/en/support/solutions/articles/22000296557-system-release-notes-4th-of-september-2026
Posted Sep 04, 2026 - 09:39 AEST
This incident affected: PlayFootball Release Notes.