Play Football Admin: Product Management - Sales Column Missing Data
Incident Report for Play Football
Resolved
This incident has been resolved.
Posted Jan 23, 2020 - 13:36 AEDT
Investigating
We are currently investigating an issue impacting the Product Management page within the Play Football Admin portal.
Posted Jan 23, 2020 - 10:51 AEDT
This incident affected: Play Football Admin Portal.