PlayFootball Release Notes (4th of March 2026)

Incident Report for PlayFootball

Resolved

Released the automated Football Account generation flow for coach and referee registrations that require access to Football Australia’s Learning Management platform
Added a label under the contact email field in the Registration on Behalf flow to highlight that the email must belong to the participant so they can access the Learning Centre.
Front‑end label only — no validation is done to check whether the guardian and participant share the same email.

Updated the confirmation screen with instructions outlining what happens next for coach and referee registrations
Introduced automated emails (based on the participant’s email) with instructions — either “no action required” or “action required,” depending on their situation
Participant’s email does not have a Football Account
→ The system will automatically create an account and send an Action Required email with steps to complete the account setup.
Participant’s email already has a Football Account linked to the same participant record as the coach/referee registration
→ A No Action Required email is sent.
Participant has a Football Account but no participant record linked
→ The system will automatically link the participant record and send a No Action Required email.
Participant’s email is already linked to a different participant record
→ An Action Required email is sent with instructions to unlink the incorrect record and link it to the correct participant.
Added the ability for participants to unlink a participant record from their account.

For more details please view > https://support.playfootball.com.au/support/solutions/articles/22000294513-system-release-notes-4th-of-march-2026
Posted Mar 04, 2026 - 08:09 AEDT
This incident affected: PlayFootball Release Notes.