PlayFootball Release Notes (25th of Feb 2026)

Incident Report for PlayFootball

Resolved

Reordered the steps in the registration flow so the Verify Identity step comes before Additional Questions

Fixed a bug where Admins were unable to delete additional questions when toggling ‘No’ for “Would you like to add your organisation’s own additional questions for your participants?”

Fixed a bug where the capacity limit was not incrementing after a participant registered and paid. There may be a few seconds’ delay before the capacity updates. The capacity not incrementing for products with no fee is still an outstanding issue

For more details please view --> https://support.playfootball.com.au/support/solutions/articles/22000294275-system-release-notes-25th-of-february-2026
Posted Feb 25, 2026 - 07:03 AEDT
This incident affected: PlayFootball Release Notes.