PlayFootball Release Notes (28th of Nov 2025)

Incident Report for PlayFootball

Resolved

Updated all references of ‘Transaction Fee’ in the system (payment screen and receipt) to ‘Service Fee’


Updated the Disbursement Report so that duplicate disbursement dates should no longer appear and the total only includes amounts that have a ‘Disbursed’ status


Removed ‘Issue Date’ as a field to populate for QLD WWCC records, as QLD does not have an issue date. The field remains required for other states.


Fixed a bug where the payment option step was always unticked for Member Federation and Assoc Admin when creating or editing a registration product


Fixed a bug where content in all full-screen pop-ups on desktop was shifted upward


Fixed a bug where an application error appeared when toggling between ‘Yes’ and ‘No’ when editing club additional questions


Fixed a bug where citation details were only displayed for club football registrations; they are now displayed for all approved registrations


Fixed a bug where the WWCC exemption requested as part of the management invite flow was not created

For more details please view > https://support.playfootball.com.au/support/solutions/articles/22000293411-system-release-notes-28th-of-november-2025
Posted Nov 28, 2025 - 07:21 AEDT
This incident affected: PlayFootball Release Notes.