Coaching and Technical Support Email Temporarily Unavailable
Incident Report for Play Football
Resolved
Our Coaching and Technical team's email is operational again.

Please direct your emails to technical@footballaustralia.com.au for all your Coaching and Technical support.
Posted Jun 02, 2023 - 13:12 AEST
Investigating
Our Coaching and Technical Support email address is currently experiencing technical difficulties and is temporarily out of order. Our team is working diligently to resolve this issue and restore normal operations as quickly as possible.

In the meantime, we apologise for any inconvenience this may cause. We are still available to support you through our alternative channels.

Phone: 02 8880 7983
Email: support@playfootball.com.au
Posted Jun 01, 2023 - 09:05 AEST
This incident affected: Coaching/Technical Support.