PlayFootball Release Notes (30th of April 2026)

Incident Report for PlayFootball

Resolved

Added the ability for Admins to view a participant’s family relationships

This is read‑only. Admins cannot invite or delete family relationships. The View Member Profile button is not yet greyed out and will currently open a blank screen — this will be updated in a future release

Immutable fields such as name and date of birth are now greyed out once a participant record is created during the registration flow (These fields cannot be edited by the participant after creation.)

Displayed the product name linked to a WWCC Exemption when previewing the exemption

Fixed date‑of‑birth formatting and a typo when Admins view a member’s profile

Fixed a bug where answers to selection‑type Additional Questions were not displaying in the All Detail Report and Participant Report

As part of this fix, answer display has also been improved (e.g. from ["a","b"] to a, b)

For more details please view > https://support.playfootball.com.au/support/solutions/articles/22000295262-system-release-notes-30th-of-april-2026
Posted Apr 30, 2026 - 08:49 AEST
This incident affected: PlayFootball Release Notes.