PlayFootball Release Notes (25th of June 2026)

Incident Report for PlayFootball

Resolved

Added a “Roles” column to the Custom Participant Report

Updated approval tickets to display who approved or declined the ticket, along with any comments provided when declining

Updated bulk select behaviour on tabs (e.g. Participant List, All Registrations) to only select records currently visible on screen
Posted Jun 26, 2026 - 10:06 AEST
This incident affected: PlayFootball Release Notes.